Revolver und aktivierte Firewall Mac OS X

Wir arbeiten bei uns mit der aktuellen Revolverversion hauptsächlich in einem Mac OSX Netzwerk und einem Mac OS X Server. Seit der Aktivierung der Mac Firewall auf allen Rechnern, bei Erlaubnis ausgehender Verbindungen für Revolver, erfolgt bei jedem Start von Revolver "Möchten Sie, dass das Programm „Revolver Office.app“ eingehende Netzwerkverbindungen akzeptiert?".

Ich vermute mal, dass wir noch einen Prozess hinzufügen müssen, damit diese Frage unterbleibt, aber welcher mag das sein?

Vielen Dank für eine kurze Antwort.

Mit Gruß

Thomas Heisterhagen
geschlossen mit Kommentar: Erledigt
2,209 Aufrufe Gefragt 1, Jan 2014 in Einstellungen von theister
geschlossen 27, Nov 2014 von bjoern.weiler

3 Antworten

 
Beste Antwort

Hallo Herr Heister,

es wäre in der Tat auch zu schön gewesen, wenn sich das Problem so trivial dargestellt hätte. Dann müssen wir halt andere Geschütze auffahren:

Ich vermute aktuell, dass es sich bei der Unschönheit um das fehlende Zertifikat in der Schlüsselbundverwaltung handelt. Seit Mavericks versichert sich die Firewall bei jedem Start von Programmen, die nicht von Apple zertifiziert sind, nach der Verbindungs-Berechtigung. Mit einem selbst erstellten Zertifikat allerdings sollte das kein Problem mehr darstellen.

  1. Öffnen Sie das Programm „Schlüsselbundverwaltung“.
  2. Wählen Sie unter „Schlüsselbundverwaltung“ in der Menüleiste den Punkt „Zertifikatsassisten ▹ Zertifikat erstellen“.
  3. Legen Sie im Fenster „Zertifikat erstellen“ zunächst einen eindeutigen Namen fest. Diesen benötigen wir später. Also gut merken!

    Identitätstyp: „Root, selbst signiert“
    Zertifikatstyp: „Code-Signierung“
    Standard-Werte überschreiben: anhaken
  4. Seriennummer: „1“
    Gültigkeit in Tagen: „900“

  5. Im nächsten Fenster editieren Sie Ihre persönlichen Daten.

  6. Die folgenden Dialoge belassen Sie in den Standard-Einstellungen und klicken sich bis zum Speichern des Zertifikates einfach durch.
  7. Öffnen Sie nun mit einem Doppelklick Ihre Zertifikats-Einstellungen.
  8. Klappen Sie die Parameter für „Zertifikat vertrauen“ auf.
  9. Wählen Sie aus der Auswahl „Immer Vertrauen“. Geben Sie Ihr Passwort ein, wenn Sie dazu aufgefordert werden.

  10. Beenden Sie nun die Schlüsselbund-Verwaltung.
  11. Laden Sie sich das Programm Xcode hier herunter und installieren Sie es.
  12. Öffnen Sie nun das Programm „Terminal“ (unter Dienstprogramme oder in Spotlight suchen).
  13. Hier geben Sie nun folgenden Befehl ein (ZERTIFIKATSNAME ersetzen Sie bitte mit dem von Ihnen vorher vergebenen Namen):

    sudo codesign -f --deep -s ZERTIFIKATSNAME /applications/Revolver\ Office.app

    Mit der Return-Taste wird der Befehl ausgeführt und das Zertifikat Revolver zugewiesen.
  14. Zur Sicherheit sollten Sie nun alle Revolver-Anwendungen und Prozesse aus Ihrer Firewall löschen und neu hinzufügen (das geht ganz wunderbar per Drag-and-Drop).

Mit diesem Workflow sollte nun die wiederholte Abfrage nach den eingehenden Verbindungen der Vergangenheit angehören.

Viele Grüße aus Aachen

Ihr Revolver-Team

Beantwortet 6, Jan 2014 von bjoern.weiler
Bearbeitet 29, Aug 2014 von bjoern.weiler

Hallo Herr Heister,

öffnen Sie bitte die Firewall-Einstellungen der Clients. 

Sie finden die Systemeinstellungen unter dem Apfel in der Menüleiste. Die Firewall-Einstellungen finden Sie unter der Rubrik „Persönlich ▹ Sicherheit“ unter dem Reiter „Firewall“.

  1. Fügen Sie einfach mit einem Klick auf das „Plus“ ein neues Programm hinzu, für das Sie eingehende Verbindungen erlauben möchten.

  1. Wählen Sie im Finder-Fenster den Pfad zu Revolver, markieren Sie Revolver und
  2. bestätigen Sie Ihre Eingabe mit einem Klick auf „Hinzufügen“.

  1. Achten Sie darauf, dass kein Haken unter „Alle eingehenden Verbindungen blockieren“ gesetzt ist.
  2. Wählen Sie hinter dem Programm-Namen die entsprechende Regel (in Ihrem Fall „Eingehende Verbindungen erlauben“) und
  3. schließen Sie die Einstellungen mit einem Klick auf den Button „OK“.

Ich hoffe, damit konnte Ihr Problem schon gelöst werden. Benutzen Sie zusätzliche Programme, wie z. B. Little Snitch, sollten Sie kontrollieren, ob nicht bei den eingestellten Regeln das Problem liegt.

Viele Grüße aus Aachen

Ihr Revolver-Team

Beantwortet 3, Jan 2014 von bjoern.weiler
Bearbeitet 3, Jan 2014 von bjoern.weiler

Hallo Herr Weiler,

 

ganz so trivial stellt sich das Problem leider nicht dar. Mir ist die grundsätzliche Vorgehensweise sehr bewusst, es funktioniert nur leider nicht. Das Problem ist nachvollziehbar an 10 Mac Rechnern mit aktuellem OS X aufgetaucht. Es wird bei jedem Aufruf von Revolver das Meldungsfenster der Firewall angezeigt, ob man eingehende Verbindungen für Revolver.app akzeptieren möchte. Erst nach dem Klck auf "Erlauben" geht es weiter. Meine Frage zielt ja darauf ab, wie man diesen Klick dauerhaft abstellen kann.

Danke und mit besten Grüßen

Thomas Heisterhagen

 

Beantwortet 3, Jan 2014 von theister
...